Customers not getting framed IP

We have all customers on Framed IP’s but over the last 3, 4 weeks the customers are getting IP’s from a DHCP pool, it seems that Zima is not writing the Remote address to some users on the Router. Its upsetting me as we have some users on 1to1 Nat and now this is not working.

Screenshot from the router



  1. Did you make any changes recently?
  2. Did you try block unblock solution?

Me using same setup but no issue found
Faced same issue during initial setup but later on working fine.

HI hssindigo,
Thanks for the reply, Just tried the block/unblock but no joy. All the DHCP adress’s seem to be coming from the default-offline pool, if I could delete that pool then I should be OK again I reckons.
However I am unable to delete it.


You need to have a offline pool for expired accounts

You can’t delete it.

Moreover, whatever may be scenario if the framed ip is specified, it should take the same ip, as in my case that’s how it’s working.


I remembered I had this issue at initial stage, what I did was create new router, move all subscribers to that router, set pppoe port, remove zima user from mikrotik, and run script of new router,

After it sync everything , it was fine.

Also note, there is a bug, do not extend expiry date it will take offline pool ip, instead use renew tab only,

A fix seems to be to enter the Remote IP manual on the router under PPP>Secrets.

Will update over the coming days

Adding router and resync would be easier and faster than adding manual ip to all secrets…

Just a thought…:slight_smile:

If I done that I would have to take everyone off line. It was only 26 users that did have the framed ip. My fix seems to be holding well.



Next time try out with a new router resync, it won’t send user offline for more than 60 seconds.

By the way how many userbase you working with?

Just under 200 users on Zima

Hi guys it happened again, this time we changed a block of users to a diferent plan and they all lost the framed IP however it shows in the user setting that they have a framed IP.

As discussed earlier, please post result of adding a new router and selecting all users move to new router.

Remove existing zima account in user and rerun script. After sync share update.

Share me your plans and ip series attached to plans that was existing and the one you moved.

I choose not to do that as I think that it over complicates things, again I just entered the 30 Framed IP’s into the router manually and it solved the problem, the only reason that i posted was to help narrow down the caise of the bug.

I dont understand what you mean ?

I meant, all your tariff created and ip pools

IP Pools
Name IP Range Allow Internet Access
default-offline NO
default-online YES

Service Plans
Add New Service Plan
Name Default Rate
10M/2M 2200k/11m 2200k/11m 1000k/2000k 10/10
10Mb_No_Shaping 2200k/10500k 2200k/10500k 1000k/2000k 10/10
15M/5M 5m/15m
20M/10M 10M/20M
2M/512k 550k/2200k 550k/2200k 500k/1000k 10/10
30M 5m/30m
3M/512k 550k/3200k 550k/3200k 540k/1000k 10/10
4M/1M 1100k/4200k 1100k/4200k 1000k/2000k 10/10
6M/1M 1200k/6200k 1200k/6200k 1000k/2000k 10/10
6M/2M 2200k/6200k 2200k/6200k 1000k/2000k 10/10
Non-Payer 20k/10k
School 2M/10M